В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AllRay1
AllRay1
15.06.2021 08:18 •  Информатика

Составить программу формирования массива на языке pascal: 1 2 n 2 0 0 0 n-1 0 0 0 0 0 0 n n-1 1

Ответ:
lphk02
lphk02
10.10.2020 01:22

Const n=5;

var a:array[1..n,1..n+1] of integer;

i,j:integer;

begin

for i:=1 to n do

begin

for j:=1 to n-i+1 do a[i,j]:=j+i-1;

for j:=n-i+2 to n+1 do a[i,j]:=0;

end;

for i:=1 to n do

begin

for j:=1 to n+1 do write(a[i,j]:2);

writeln;

end;

end.


Результат:

1 2 3 4 5 0

2 3 4 5 0 0

3 4 5 0 0 0

4 5 0 0 0 0

5 0 0 0 0 0


Вроде так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?