В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на c++ для вывода на экран в столбик все цифры переданного ей числа , начиная с первой. пример : введите натуральное число : 1234 1 2 3 4

Ответ:
ycidenis1
ycidenis1
04.10.2020 19:27
#include <iostream>
using namespace std;

int main()
{
    int a;
    int b =0;
    cout << "Введите натуральное число :", cin >> a, cout << "\n";
    while (a>0){
    b = b*10+(a%10);
    a = a/10;
    }
    while (b>0){
    cout << b%10 << "\n";
    b = b / 10;
    }
    return 0;
}

Пример:
Введите натуральное число : 8025
8
0
2
5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?