Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
daruapolo
26.06.2020 03:02 •
Информатика
Сформируйте и выведите целочисленный массив содержащий степени двойки от первой до 16
Ответ:
ТОХА2287
03.10.2020 06:05
Да если судить по предыдущем решению, "в школу снова не хочу!" )))
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
Range(1,16).Select(x->Power(2,x)).ToArray.Println
end.
Тестовое решение:
2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 32768 65536
Замечание: ToArray. можно выбросить и написать
Range(1,16).Select(x->Power(2,x)).Println - это была просто дань требованию условия зачем-то создать массив и вывести его значения.
0,0
(0 оценок)
Ответ:
Шаша676
03.10.2020 06:05
Program Project1;
var
a:array[1..16] of integer;
i,p:integer;
begin
p:=1;
for i:=1 to 16 do
begin
p:=p*2;
a[ i ]:=p;
writeln(a[ i ])
end;
readln
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ritikdf345
13.03.2022 20:26
7. Дұрыс теңдікті тап: А) 2 Мбайт = 2048 КбайтӘ) 8 Кбайт = 1024 байтБ) 16 бит = 4 байтВ) 4 байт = 64 бит...
wormer221
04.03.2020 01:05
Найти произведение k - натуральных чисел кратных 3...
9яна2005
04.03.2020 01:05
Составить программу для вычисления длин высот треугольника , у которого длины сторон abc...
yaxyeu
04.03.2020 01:05
Определите объём памяти в кбайтах, занимаемый текстом из 60 страниц по 512 символов на каждой странице. (кодировка ascii)...
vasxodd1
16.08.2022 01:30
Дано число n. найти все его делители....
nnnnn777
08.01.2021 18:04
Впрограмме описан одномерный целочисленный массив с индексами от 0 до 10. s: =0 n: =10 for i: =0 to n-2 do begin s: =s+a[i]-a[i+2] в начале выполнения этого фрагмента в массиве находились...
Tyyyooo
14.11.2021 10:51
Быстреее осталось 4 мин я потом ещё ответ лутшем сделаю...
vasilevamarin
20.12.2020 16:59
Определи два правила соблюдения эргономики работы за компьютером в отношении освещения рабочего места. Верных ответов: 2 Искусственный свет должен освещать только монитор Освещение...
kamila285
08.10.2020 10:24
Кто паможет только памогите! Вопрос 1 ?По какой кнопке или ссылке можно увидеть. Что к электронному письму прикреплены вложенные файлы?Вопрос №2 ? Как называется файл, который отсылается...
YTTeamGardnYT
29.03.2021 14:10
Почему пожилые люди когда им плохо слышно прикладывают ладони к ушам...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
Range(1,16).Select(x->Power(2,x)).ToArray.Println
end.
Тестовое решение:
2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 32768 65536
Замечание: ToArray. можно выбросить и написать
Range(1,16).Select(x->Power(2,x)).Println - это была просто дань требованию условия зачем-то создать массив и вывести его значения.
var
a:array[1..16] of integer;
i,p:integer;
begin
p:=1;
for i:=1 to 16 do
begin
p:=p*2;
a[ i ]:=p;
writeln(a[ i ])
end;
readln
end.