В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rhhufyko
Rhhufyko
03.08.2022 12:32 •  Информатика

Составить программу, в которой осуществляется ввод целых чисел, (пока не будет введен ноль) и подсчет количества введенных положительных и отрицательных чисел через оператор не соображаю в этой теме хороших людей))

Ответ:
aalenka592
aalenka592
09.10.2020 06:54

begin

 var n: integer;

 var (CountP, CountN) := (0, 0);

 while True do

 begin

   Read(n);

   if n > 0 then CountP += 1

   else if n < 0 then CountN += 1

   else break

 end;

 Write('Положительных: ', CountP,

 NewLine, 'Отрицательных: ', CountN)

end.


Составить программу, в которой осуществляется ввод целых чисел, (пока не будет введен ноль) и подсче
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?