В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
аноним991
аноним991
26.02.2020 19:08 •  Информатика

1) составить программу, которая находит сумму всех натуральных чисел от 20 до 30.

Ответ:
diasjabarrrrrrrr
diasjabarrrrrrrr
25.05.2020 08:43

Сумма натуральных чисел от 20 до 30 составляет арифметическую прогрессию, состоящую из 11 членов. Первый член прогрессии: 20, разность прогрессии - 1. По формуле суммы n членов прогрессии составим программу.

S_{n=\frac{a_{1}+a_{n} }{2}*n

Решение на языке Pascal:

var  n: real;

begin

 n := (20 + 30) / 2 * 11;

 writeln(n);

end.

Иное решение: с цикла просуммируем все числа от 20 до 30.

var

 i, s: integer;  

begin

 s := 0;

 for i := 20 to 30 do

   s := s + i;

   writeln(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?