В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
wjp39391
wjp39391
25.02.2023 15:39 •  Информатика

Составьте программу, которая выводит последовательность чисел 1 2 3 4 5 и 5 4 3 2 1, используя циклwhile. и такую же программу используя цикл repeat. pascal

Ответ:
TTpopoK
TTpopoK
27.08.2020 07:49
Var
  i: integer;
begin
i := 1;
while i <= 5 do begin
writeln (i);
i := i + 1
end;
while i >= 1 do begin
writeln (i);
i := i - 1
end;
end.
0,0(0 оценок)
Ответ:
Aрiшkа
Aрiшkа
27.08.2020 07:49
// PascalABC.NET

// Цикл While
begin
   var i := 1;
   
   while i < 6 do 
   begin
      write(i, ' ');
      inc(i);
   end;
   
   writeln;
   dec(i);
   
   while i > 0 do
   begin
      write(i, ' ');
      dec(i)
   end
end.

// Цикл Repeat
begin
   var i := 1;
   
   repeat
      write(i, ' ');
      inc(i);
   until i>5;
   
   writeln;
   dec(i);
   
   repeat
      write(i, ' ');
      dec(i)
   until i<1
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?