В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Starshine2007
Starshine2007
23.01.2020 21:15 •  Информатика

Написать программу, которая выводит синусы и косинусы. на языке си. заранее

Ответ:
Raptords
Raptords
27.05.2020 21:01

1) Си-для начала  переменные нужно в начало функции объявлять. Если компилятор у тебя си как бы сказать си-шный,тои файл будет тоже си-шный
2)Самым первым аргументом для синуса и косинуса и формула пов(pow)будет вещественное число.
Так,косинус  и синус:
 cos(Xnumber,4) 
У функции синус и косинус только один параметр, а у pow совсем наоборот. 
 double Xnumber; и другие
I)все переменные нужно объявить , как double.  
Читать нужно будет так:
scanf("%lf", &Xnumber);
 тебе нужна для пов(pow)?
если да?,то вот:
Пов(pow)pow(cos(Xnumber), 4) + pow(sin(Ynumber), 2) + 1.0 / 4 * pow(sin(2*Xnumber), 2) - 1;
Вроде все,если понял(а),а если нет,то пиши в сообщение,и спрашивай,что не понятно
 

0,0(0 оценок)
Ответ:
mashalin44
mashalin44
27.05.2020 21:01

#include < iostream >    /* Подключаем библиотеку, чтоб работали функции cout, cin */
#include < cmath >    /*Подкючаем библиотеку, чтоб работали функции cos, pi */
#define PI 3.14159265   /*Задаем сколько у нас будет значит число ПИ */
using namespace std;

main (){  
         float a, result;   /*Вводим 2 переменные - действительные числа: одно - число градусов угла, второе - полученный результат*/
         cout << "Vvedite znachenie ugla" << endl;
         cin >> a;   /* Вводим значение угла с клавиатуры*/
         result = cos (a*PI/180);    /*высчитываем значение косинуса, переводя значениезаданного угла в радианы */
         cout << "Kosinus "<< a << " raven " << result;    /*Выводим полученное на экран */
         return 0;    /*Возвращает нулевое значение */
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?