В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
никотян7
никотян7
07.04.2022 20:15 •  Информатика

Составить программу которая создаёт массив случайных чисел в диапазоне (-10,10) . найти сумму положительных и сумму отрицательных элементов массива

Ответ:
zeynalova79
zeynalova79
07.10.2020 20:25
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
var a:=ArrRandom(10,-10,10);a.Println;
var (sum1,sum2):= (a.Where(t -> t > 0).Sum,a.Where(t -> t < 0).Sum);
Writeln(sum1, ' ', sum2);
end.

Пример:
5 -2 -3 6 -7 -8 -7 7 -1 4
22 -28
0,0(0 оценок)
Ответ:
stella201
stella201
07.10.2020 20:25
Const
  nn=100;

var
  i,n,sn,sp:integer;
  a:array[1..nn] of integer;

begin
  Write('n = '); Read(n);
  Randomize;
  sn:=0; sp:=0;
  for i:=1 to n do begin
    a[i]:=Random(21)-10;
    Write(a[i],' ');
    if a[i]>0 then sp:=sp+a[i]
    else
      if a[i]<0 then sn:=sn+a[i]
    end;
  Writeln;
  Writeln('Сумма отрицательных ',sn,', сумма положительных ',sp)
end.

Пример
n = 13
8 4 10 6 -2 2 -9 -9 6 3 2 4 -7
Сумма отрицательных -27, сумма положительных 45
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?