Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ichi2209
17.06.2021 02:53 •
Информатика
Напишите программу которая для числа выводит значение тригонометрических функцийю sin и cos например вводим 180 программа выводит sin(180)=0 и cos(180)=-1
Ответ:
Alexandr201755
20.09.2020 07:25
Вот программа и результат ее работы (смотри скриншоты)
А вот ее листинг:
uses Crt;
var alfa, a, s, c:real;
begin
ClrScr;
Write (' alfa = ');
ReadLn (alfa);
a:= alfa*pi/180;
s:=sin(a);
c:=cos(a);
WriteLn;
WriteLn ( 'sin','(',alfa:3:0, ') = ', s:6:2);
WriteLn ( 'cos','(',alfa:3:0, ') = ', c:6:2);
ReadLn;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
yoeru
21.01.2022 15:57
Найти объем текста ht,записанного на языке,алфавит которого содержит n=128 символов и k=2000 символов в сообщении...
galaninartem201
29.04.2020 23:17
Сформулировать 12 случайных чисел в промежуток [- 3,12 ]найти количество отрицательных чисел...
dedovdima14
19.08.2022 06:54
с задачей в Python. Сделать с генератора псевдослучайных чисел, оператор in, not in. Задача: Найти наиболее часто встречающийся элемент в списке целых чисел. Cписок из целых...
samsunguser
29.03.2020 20:05
Марина сделала презентацию и решила отправить ее диме определите сколько для этого понадобится времени в минутах если объём презентации равен 9000 а скорость передачи данных...
rast2k17
15.03.2023 04:24
Вопрос № 4 4. информация: открытая, закрытая, конфиденциальная…выберите параметр, по которому произведена классификация ир тематика хранящейся информации доступность информацииназначение...
makaroshkaplay
15.03.2023 04:24
Даны две матрицы x(5,5) и y(4,4). найти сумму отрицательных элементов матриц и сравнить, у какой из матриц она больше. нужно сделать программу на языке паскаль через массив....
mpavl8628
15.03.2023 04:24
Постройте электронную таблицу оплата электроэнергии для расчёта ежемесячной платы за расход электроэнергии в течение года. исходный информацией являются показания счетчика...
mariuaivanova1
18.05.2023 21:09
Как переводится слово с языка на мокшанский музыка...
Korolinaaa
18.05.2023 21:09
Написать вывод, о произошедших изменениях в мире за период 1990-2000, по сравнению с изменениями 80-х годов. на пол листа, кратенько. (имеются ввиду изменения в политике,...
Kristina018191999
18.05.2023 21:09
Как решить дробь семь двенадцатых минус пять девятых...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
А вот ее листинг:
uses Crt;
var alfa, a, s, c:real;
begin
ClrScr;
Write (' alfa = ');
ReadLn (alfa);
a:= alfa*pi/180;
s:=sin(a);
c:=cos(a);
WriteLn;
WriteLn ( 'sin','(',alfa:3:0, ') = ', s:6:2);
WriteLn ( 'cos','(',alfa:3:0, ') = ', c:6:2);
ReadLn;
end.