В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
moroshan77
moroshan77
15.12.2021 20:39 •  Информатика

Составить программу на паскале. расчитать доход за весь гот по месяцам. пример: в первый месяц мы получили 100р, во второй 102р. но! учесть что и проценты тоже растут.

Ответ:
аьвтчьвь
аьвтчьвь
07.10.2020 14:52
// PascalABC.NET 3.3
// Cборка 1590 от 03.12.2017

begin
  var a:=ReadReal('Введите зарплату в первый месяц->');
  var z:=0.00;
  for var i:=1 to 12 do
   begin
    Writeln('Доход за ',i,' месяц составил ',a:0:2,'р.');
    z+=a;
    a:=a+a*0.1;
   end;
  Writeln('Зарплата за год: ',z:0:2,'р.');  
end.

Пример:
Введите зарплату в первый месяц-> 100
Доход за 1 месяц составил 100.00 р.
Доход за 2 месяц составил 110.00 р.
Доход за 3 месяц составил 121.00 р.
Доход за 4 месяц составил 133.10 р.
Доход за 5 месяц составил 146.41 р.
Доход за 6 месяц составил 161.05 р.
Доход за 7 месяц составил 177.16 р.
Доход за 8 месяц составил 194.87 р.
Доход за 9 месяц составил 214.36 р.
Доход за 10 месяц составил 235.79 р.
Доход за 11 месяц составил 259.37 р.
Доход за 12 месяц составил 285.31 р.
Зарплата за год: 2138.43 р

P.S Сделал как понял.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?