В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
basemaker
basemaker
21.09.2022 16:16 •  Информатика

Написать программу на найти наибольшую цифру числа и ее порядковый номер и найти сумму наибольшей и наименьшей цифры.

Ответ:
milayakisa1
milayakisa1
05.10.2020 19:44
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('n=');
  var p:=s.ToCharArray.IndexMax;
  Writeln('Максимальная цифра ',s[p+1],' имеет номер ',p+1);
  Writeln('Сумма наибольшей и наименьшей цифр равна ',
    s.Min.ToDigit+s.Max.ToDigit)
end.

Пример
n= 145384
Максимальная цифра 8 имеет номер 5
Сумма наибольшей и наименьшей цифр равна 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?