В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1230a
1230a
11.05.2023 07:23 •  Информатика

Написать программу удаления половины символов, зная, что количество символов в строке - чётное. (паскаль)

Ответ:
KozyrevaAlbina
KozyrevaAlbina
20.08.2020 18:54
Для удаления правой половины символов:

Var
   S:string;
Begin
Write('Введите строку: ');ReadLn(S);
S:=Copy(S,1,Length(S) div 2);
WriteLn(S);
End.

Пример работы программы:

Введите строку: 1234
12

Для удаления левой половины символов:

Var
   S:string;
Begin
Write('Введите строку: ');ReadLn(S);
S:=Copy(S,Length(S) div 2+1, Length(S));
WriteLn(S);
End.

Пример работы программы:

Введите строку: 1234
34

Удаление выбранной половины символов:

Var
   S:string;
   A:byte;
Begin
Write('Введите строку: ');ReadLn(S);
WriteLn('1 - удаление правой половины, 2 - удаление левой половины');
ReadLn(A);
if A = 1 then S:=Copy(S,Length(S) div 2+1, Length(S))
else S:=Copy(S,1,Length(S) div 2);
WriteLn(S);
End.

Пример работы программы:

Введите строку: 1234567890
1 - удаление правой половины, 2 - удаление левой половины
2
12345
0,0(0 оценок)
Ответ:
эги1
эги1
20.08.2020 18:54
1. Современный вариант
// PascalABC.NET 3.2, сборка 1429 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  s:=s.Left(s.Length div 2);
  s.Println
end.

Пример
Половину удалим!
Половину

2. Школьный вариант
var
  s:string;
  n:integer;
begin
  Readln(s);
  n:=Length(s) div 2;
  Delete(s,n+1,n);
  Writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?