Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Abdueva
04.03.2022 02:13 •
Информатика
Составьте программу. для вводимых с клавиатуры чисел определить количество положительных. ввод чисел прекращается, когда пользователь вводит 0.
Ответ:
megakrykova
06.10.2020 04:36
Var a,k:integer;
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3
0,0
(0 оценок)
Популярные вопросы: Информатика
tanya150452
13.09.2020 12:46
Вычислите с калькулятора (приложение Windows) в режиме «Программист» следующие примеры: 1) 111011101^2 — 1101110110^2;2) 1101101001^2 — 11000100100^2.Как вы можете...
ЛАЙФСТААААААЙЛ
07.02.2021 05:57
Составить программу на паскале которая определяет является ли х введённая с клавиатуры корнем уравнения : корень из х+3 -1/х+х2-2=0...
кар91
15.10.2022 09:31
Постройте дерево каталогов с: \рисунки\города\томск.bmp c: \рисунки\природа\бор.jpg с: \документы\компьютеры\принтер.gif c\ мои документы\учебные\реферат.doc c:...
sulfaandrey
15.10.2022 09:31
С# 1. создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. выведите значения элементов массива в строку, разделив...
qqwrrtu
15.10.2022 09:31
Каков объём жёсткого диска компьютера, к которому вы имеете доступ дома или в школе? (можно в пример свой компьютер, не имеет значения)....
vikazelenaya1
15.10.2022 09:31
Составить программу которая вводит 5 чисел и подсчитывает количество четных и нечётных чисел нужно...
ляпрпммм
30.11.2022 02:11
Что используют для измерения массы? Что используют для измерения длины? Что используют для измерения премени? Что используют для измерения температуры?...
эмриханастчсия
25.01.2022 20:26
Определи подходящий вид алгоритма: Марат пригласил друзей поиграть компьютерные игры и решил подготовить 5 одинаковых бутербродов. ветвления линейный повторяющийся...
Lilithovhannisyan
15.06.2021 15:39
14. В ячейку B15 ввели формулу =(С6 – $D$6)*$E$6. Затем эту формулу рас вниз. Какая формула содержится в ячейке B18?...
ilqartural2005
09.10.2020 10:15
Найти наибольший корень уравнения решить уравнение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3