В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
янннак
янннак
03.04.2023 07:36 •  Информатика

Составьте программу. для вводимых с клавиатуры чисел определить количество четных и сумму нечетных чисел. ввод прекращается когда пользователь вводит цифру 0

Ответ:
mxitaryan77
mxitaryan77
31.08.2020 23:48
Var A,c:longint;
    S:real;
Begin
c:=-1;
S:=0;
Repeat
Read(A);
if A mod 2 = 0 then c:=c+1
else S:=S+A;
Until A = 0;
WriteLn('Количество чётных: ',c);
WriteLn('Сумма нечётных: ',S);
End.

Пример работы программы:

1 2 3 4 5 6 7 8 9 10 0
Количество чётных: 5
Сумма нечётных: 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?