Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Адриана111111111
27.04.2020 13:47 •
Информатика
Pascal. в одномерном массиве элементы меньше 1 умножить на 2,а остальные увеличить на 3
Ответ:
pollllyyy
05.10.2020 18:33
Var
x:array [1..10] of integer;
i:integer;
begin
writeln('Введите массив');
for i:=1 to 10 do begin
read(x[i]);
if x[i]<1 then
x[i]:=x[i]*2
else
x[i]:=x[i]+3;
end;
for i:=1 to 10 do
write(x[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
gr3ygo0se
21.04.2020 08:16
Составить программу которая показывает количество чётных чисел между числами а и б. с клавиатуры вводятся два числа а выводится количество чётных чисел между ними. ! !...
elektroo67
21.04.2020 08:16
1.укажите, сколько раз выполнится тело цикла с заданным заголовком: for i: = -1 to 2 do; a)4 б)0 в)3 г)бесконечное число раз 2.укажите, сколько раз выполнится тело цикла с заданным...
ert12375
20.10.2021 14:41
Найдите все десятичные числа, не превосходящие 26, запись которых в троичной системе счисления заканчивается на 22....
perecnikova
20.10.2021 14:41
Мини-доклад хранения информации...
daniil6092002
20.10.2021 14:41
По данным двум натуральным числам a и b (a≤b) выведите все чётные числа на отрезке от a до b. в этой нельзя использовать инструкцию if. входные данные вводятся два натуральных...
sanfirovngmail
20.10.2021 14:41
Задали ,как решать без понятия! : написать программу, определяющую, равнобедренный или нет треугольник, если даны все 3 стороны...
galina157
20.10.2021 14:41
Чему равна сумма чисел а=70(16) и b=17(8)? 107(8) 10000111(2) 87(16) 7f(16)...
kristinavasina1
02.07.2022 17:20
5. « Самое сложное в жизни человека- это познание самого себя!» - кому принадлежитвысказывание?A) Сократ Б) Аристотель B) Милетский ) Айтматов...
madam7952
02.07.2022 17:20
Какое событие в произведении М.Ю. Лермонтова «Бородино» является развязкой? ( за правильный ответ) A. два дня перестрелкиB. битва за МосквуC. отступление французовD. ликование...
Хурем
25.01.2022 20:16
Язык python 1. Введите значение n. Выведите все степени двойки которые меньше или равно введенному числу. (10) sample input 50 sample output 2 4 8 16 32 2. Введите значение n....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x:array [1..10] of integer;
i:integer;
begin
writeln('Введите массив');
for i:=1 to 10 do begin
read(x[i]);
if x[i]<1 then
x[i]:=x[i]*2
else
x[i]:=x[i]+3;
end;
for i:=1 to 10 do
write(x[i],' ');
end.