В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lanceva3
lanceva3
22.01.2020 04:40 •  Информатика

Написать программу нахождения наибольшего значения их пяти переменных

Ответ:
Аня199823
Аня199823
09.08.2020 16:57
Var a,b,c,d,e,max:integer;
begin 
writeln('a, b, c, d, e:');
readln(a,b,c,d,e);
If a>b then max:=a else max:=b;
If c>max then max:=c;
If d>max then max:=d;
If e>max then max:=e;
Writeln('max = ',max);
End.

Пример:
a, b, c, d, e:
8 5 2 9 4
max = 9
0,0(0 оценок)
Ответ:
Topxic
Topxic
09.08.2020 16:57
Var a,b,c,d,e,max:integer;
begin
readln(a,b,c,d,e);
If (a>b) and (a>c) and (a>d) and (a>e) then max:=a;
If (b>a) and (b>c) and (b>d) and (b>e) then max:=b;
If (c>a) and (c>b) and (c>d) and (c>e) then max:=c;
If (d>a) and (d>b) and (d>c) and (d>e) then max:=d;
If (e>a) and (e>b) and (e>c) and (e>d) then max:=e;
Writeln(max);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?