Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
kozaksolomia1
21.02.2022 00:38 •
Информатика
Составьте программу, которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов
Ответ:
0Lvovich0
20.08.2020 09:28
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-45,45); a.Println;
Swap(a[0],a[9]); a.Println
end.
Пример
32 -1 21 17 13 11 -7 14 -7 4
4 -1 21 17 13 11 -7 14 -7 32
0,0
(0 оценок)
Ответ:
hanbek81
20.08.2020 09:28
Type mas= Array [1..10] of integer;
var i,M:integer;
a:mas;
begin
randomize;
for i:=1 to 10
do begin
A[i]:=random (-45,45);
write(A[i],' ');
end;
writeln();
A[1]:=M
A[i]:=A[10];
A[10]:=M;
for i:=1 to 10
do write(A[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
artem880
01.08.2021 11:34
Составьте программу, которая определяет, является ли введеное с клавиатуры целое трехзначное число палиндромом, т. е. читается одинаково слево направо и справа налево...
senan53
05.07.2020 04:14
Напишите программу определения объёма, который при нормальных условиях займёт кислород, имеющий массу m граммов по формуле v=m/r, где r=1,42897 - плотность кислорода....
biersacknikita9
05.09.2020 10:56
Даны натуральные числа x и y. вычислить произведение x*y, используя лишь сложение. язык программирования: паскаль....
Natalym2001
05.09.2020 10:56
Сколько символов содержится в алфавите, при которого написана книга из 20 страниц, на каждой из которых содержится 15 строк по 20 символов и занимает в памяти компьютера вся книга...
Superymniaha
05.09.2020 10:56
Составить программу вывода любого числа любое заданное число раз в одну строчку. язык программирования: паскаль....
NikaName007
21.06.2020 11:50
Почему первой в космос отправили собаку?...
anna47983
21.06.2020 11:50
25 напишите эссе на тему правописание безударных гласных, глухих и звонких согласных...
ushepbegjan
21.06.2020 11:50
Мне нужен доклад на тему роль живых организмов...
ffghh1gfdd
21.06.2020 11:50
Выражения 3(х+5)=3х+15 (3+5)х=3х+5х (7+х)*5=7*5+8*5 (х+2)*4=2*4+2*4 (5-3)х=5х-3х (5-3)х=5х-3*2...
ramzinakadenbaeva
21.06.2020 11:50
Где и когда открыта первая светская школа а казахстане...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-45,45); a.Println;
Swap(a[0],a[9]); a.Println
end.
Пример
32 -1 21 17 13 11 -7 14 -7 4
4 -1 21 17 13 11 -7 14 -7 32
var i,M:integer;
a:mas;
begin
randomize;
for i:=1 to 10
do begin
A[i]:=random (-45,45);
write(A[i],' ');
end;
writeln();
A[1]:=M
A[i]:=A[10];
A[10]:=M;
for i:=1 to 10
do write(A[i],' ');
end.