В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу, которая формирует массив из десяти случайных целых чисел от 100 до 150 и увеличивает в два раза числа, кратные 5, а остальные уменьшает в 2 раза

Ответ:
xenia00000
xenia00000
04.10.2020 22:18
#include <iostream>
using namespace std;

int main() {
const int SIZE = 10;
int a[SIZE];
size_t i;
for(i = 0; i < SIZE; i++) {
a[i] = rand() % 51 + 100;
cout << "a[" << i << "] = " << a[i] << '\n';
if (a[i] % 5 == 0)
a[i] = 2* a[i];
else
a[i] = (int) a[i]/2;
}
cout << "" << '\n';
for(i = 0; i < SIZE; i++) {
cout << "a[" << i << "] = " << a[i] << '\n';
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?