В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Знание111111
Знание111111
23.11.2022 15:57 •  Информатика

30 ! программисту владу грустно: на дворе новый год, но он не может принести домой ёлку, потому что у его кота барсика аллергия. владу написать программу, принимающую на вход целое положительное число n, и выводящую на экран последовательность от 1 до n "ёлочкой", чтобы у влада хоть где-то она была. формат ввода строка, содержащая чило n. формат вывода ёлочка из нескольких строк. на python

Ответ:
nikzhukov989
nikzhukov989
02.09.2020 13:24

n = int(input())

 

q = 1

s = 1

k = 0

while q <= n :

   print(q, end=' ')

   q = q + 1

   k = k + 1

   if k == s :

       print()

       s = s + 1

       k = 0

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?