В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kedr3
kedr3
05.07.2021 23:21 •  Информатика

29 . , , написать программу и блок-схему: ввести целое число и найти сумму его цифр.

Ответ:
Богдансупе23
Богдансупе23
04.10.2020 10:07
Блок-схема - в прилагаемом файле. Программа:
var n,s:integer;
begin
write('n = ');
readln(n);
n:=abs(n);s:=0;
while n>0 do begin s:=s+n mod 10;
 n:=n div 10;
 end;
writeln('s = ',s);
end.

Пример:
n = -62845
s = 25
29 . , , написать программу и блок-схему: ввести целое число и найти сумму его цифр.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?