Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
adelina121212
19.10.2020 10:30 •
Информатика
Напишите программу на языке паскаля через цикл while, которая определяет максимальное из введенных чисел с клавиатуры(ввод чисел заканчивается числом 0).
Ответ:
Winny1111
01.10.2020 20:42
Program red;
var a,max:integer;
begin
max:=-10000;
readln(a);
while a<>0 do begin
if max<a then max:=a;
readln(a);
end;
writeln(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nataliy6578
15.11.2021 00:28
0..9: whitelh (однозначное) 10..99: writelh (двузначное) 100..999: writelh (трёхзначное) 1000..9999: writelh (четырёхзначное) 10000..99999: writelh (пятизначное) end вводится оценка...
Alisialove
15.11.2021 00:28
Найдите минимальное положительное xx такое, что если результат вычисления выражения 7417(8) + x(10) перевести в двоичную систему счисления, то запись будет содержать только цифры...
CrySony1
14.10.2021 21:17
Современные устройства передачи и древние учтройства передачи....
malini20
14.10.2021 21:17
Что лучше мармелад или шоколад и почему?...
маоия051209
14.10.2021 21:17
Компьютер имеет оперативную память 2048 мбайт. если записать эту величину в битах, то какая степень числа 2 будет соответствовать этой величине:...
halker249Neekolay
14.10.2021 21:17
Вчём выражаются отрицательные черты развития информатики?...
revunova
27.02.2020 10:49
Здравствуйте тапсырма что и как нужно делать?заранее большое...
Leraekb2012
28.07.2020 11:32
3 Write sentences, Predict the future for you and your friends.Eva will write a book.1 write a book2 visit China3 buy a fast car4 become a teacher5 be on TV...
Петунья248
19.06.2021 08:48
Русский язык шестой класс бреусенко упражнение два...
Diana2004250
07.10.2021 20:16
Как назватьодним словом знак внимания к старшему или младшему ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,max:integer;
begin
max:=-10000;
readln(a);
while a<>0 do begin
if max<a then max:=a;
readln(a);
end;
writeln(max);
end.