В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
JustNika
JustNika
16.04.2022 01:18 •  Информатика

Написать программу (pascal) заполнить массив заданной длины различными простыми числами начиная с 2. натуральное число, большее единицы, называется простым, если оно делится только на себя и на единицу.

Ответ:
tamer20052
tamer20052
25.09.2020 07:52
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var
  a: array of integer;
  i, n, m: integer;
function simple(x:integer): boolean;
var
  i: integer;
begin
  Simple := false;
  if x < 2 then exit;
  if x mod 2 = 0 then exit;
  i := 3;
  while i <= sqrt(x) do
  begin
    if x mod i = 0 then exit;
    i +=2;
  end;
  Simple := true;
end;

begin
  write('Количество элементов массива :');readln(m);
  SetLength(a, m);
  while n <= m - 1 do
  begin
    if simple(i) then begin
      a[n] := i;
      n +=1;
    end;
    i +=1;
  end;
a.println;  
end.

Тестовое решение:
Количество элементов массива :25
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?