В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
CoolCaroot
CoolCaroot
17.01.2020 05:06 •  Информатика

Тема: рекуррентные соотношения. написать программу для вывода последовательности условие: b1=5; bn=(-1)^n * bn-1 -8 минус 1 в степени n, умножить на b n-1 (n-1 -> подстрочный текст) - 8 начинаю писать программу, а в степень без
понятия как возвести program posledovatelnost; uses crt; var i,n: integer; b1,bn: real; begin clrscr; writeln ('введите n'); readln (n); b1: =5; writeln ('1 элемент = ', b1); for i: =2 to n do begin bn: = writeln (i, 'элемент = ', bn); b1: =bn; end; readln end. что написать, чтобы считать правильно bn,
нужно чтобы работало в tp, поэтому power,pow и exp бесполезны.

Ответ:
умпцнмп
умпцнмп
08.05.2020 06:56

var

b1,b2,i,n,p:integer;

begin

write('введите n');
readln (n);
b1:=5;
writeln ('1 элемент = ', b1);

p:=-1;

for i:=2 to n do

begin

p:=p*(-1);

b2:=p*b1-8;

writeln (i,' элемент = ', b2);

b1:=b2;

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?