В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lira0804
lira0804
11.05.2021 19:38 •  Информатика

Впаскале написать программу: автоматический массив, состоящий из 10 элементов. нужно убрать из него все отрицательные числа, заменив их 0. и при этом все нули (если они уже есть или замененные отрицательные числа) переставить в конец,

Ответ:
KIRILL1231321312
KIRILL1231321312
27.05.2020 23:47

program noname;
uses crt;
var
a,b:array[1..1000] of integer;
i,j,k:integer;
begin
clrscr;
for i:=1 to 10 do
begin
write('a[',i,']=');
readln(a[i]);
b[i]:=0;
if a[i]<0 then a[i]:=0;
end;
j:=1;
for i:=1 to 10 do
if a[i]<>0 then begin b[j]:=a[i]; j:=j+1; end;
for i:=1 to 10 do
write(b[i],' ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?