В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
karina200612
karina200612
29.01.2022 14:44 •  Информатика

Напишите программу )) дан массив действительных чисел.среди них есть равные .найти первый максимальный элемент массива и заменить его нулём

Ответ:
nikita1241
nikita1241
24.05.2020 06:53

Program num1;
Uses crt;
Var x:array[1..10] of real;
max:real;
i : integer;
Begin
clrscr;
for i:=1 to 10 do
begin
write('x[',i,']=');readln(x[i])
end;
max:=x[1];
for i:=1 to 10 do
if x[i]>=max then max:=x[i];
Writeln('Max=',max:3:1);
for i:=1 to 10 do
if x[i]=max then begin x[i]:=0;break end;
for i:=1 to 10 do write(' *',x[i]:3:1,'* ');
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?