В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
TPROfesorT
TPROfesorT
28.10.2021 03:42 •  Информатика

Составить программу для нахождения количества таких трехзначных чисел фибоначчи, которые делятся на сумму своих цифр нацело. программа - pascal abc

Ответ:
Диля222222222
Диля222222222
03.10.2020 08:41
Var
 a,b,k,s: integer;
begin
 k := 0;
 a := 1;
 b := 1;
 while b < 1000 do
   begin
   if b >= 100 then
     begin
     s := b div 100 + b div 10 mod 10 + b mod 10;
     if b mod s = 0 then
       k := k + 1
     end;
   b := a + b;
   a := b - a;
   end;
 write(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?