В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bissimbayevaa
bissimbayevaa
05.10.2021 21:23 •  Информатика

Написать программу, сокращающую обыкновенные дроби. числитель и знаменатель вводятся с клавиатуры. в программе использовать цикл с постусловием. пример. вводятся числа: 10 15 результат: 2 / 3

Ответ:
romanvailev15
romanvailev15
27.05.2020 18:14

var i,x,y:integer;
b:boolean;
begin
readln(x,y);
for i:=2 to x do
if (x div i=x/i) and (y div i=y/i) then begin
x:=x div i;
y:=y div i;
end;
writeln(x,' ',y);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?