В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dimaa299
Dimaa299
14.11.2021 02:33 •  Информатика

Написать программу на паскале : ) составить программу, проверяющую, являются ли данные три числа взаимно простыми. использовать подпрограмму.

Ответ:
elya144
elya144
03.10.2020 03:09
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
  a, b, c: integer;

{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
  while b > 0 do
  begin
    t := b;
    b := a mod b;
    a := t;
  end;
  gcd := a;
end;

{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
  isCoprime := gcd(gcd(a, b), c) = 1;
end;

begin
  read(a, b, c);
  if isCoprime(a, b, c) then write('Числа взаимно простые')
                        else write('Числа не являются взаимно простыми');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?