В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ushhahas02828
ushhahas02828
06.08.2021 21:52 •  Информатика

Напишите программу, запрашивающую у пользователя n целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел. ( на языке паскаль с++)

Ответ:
коршун4
коршун4
03.10.2020 01:42
Program z1;  Var i,n,a,b,c:integer;      m: array [1..1000] of integer;Begin  write('Введите кол-во чисел - ');  readln(n);   randomize;   a:=0;   b:=0;   c:=0;  for i:=1 to n do  begin    m[i]:=random(100)-50;    write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?