Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
kgatikha1
04.03.2023 11:04 •
Информатика
Составить программу ,которая будет выдавать последовательность квадратов натуральных чисел от 1 до n, где n вводится с экрана.заранее
Ответ:
lovemopeio
08.10.2020 06:39
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!
begin
1.To(ReadInteger('n=')).Select(t->t*t).Println
end.
Пример
n= 30
1 4 9 16 25 36 49 64 81 100 121 144 169 196 225 256 289 324 361 400 441 484 529 576 625 676 729 784 841 900
0,0
(0 оценок)
Ответ:
Gir9
08.10.2020 06:39
var x,n: integer;
begin
write('n = ');
readln(n);
x := 1;
while sqr(x) < n do begin write(sqr(x),' ');
x := x + 1 end;
readln
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
aruuuukaa12
28.11.2020 11:25
Як записати алгоритм перегляду вмiст папки ?...
DesertTwo1
28.11.2020 11:25
Напишите следующую программу на языке паскаль. даны целые числа а,в и с. если а или = b или равно с, то все числа замените их квадратами, если а b c, то каждое число замените наибольшим...
Daffynsky01
02.08.2022 08:37
Показать, какое число больше 47(8) или аf(16)...
Ксения1802
02.08.2021 22:00
Информационная безопасность Программ или данных резервной копии • резервные копии • физическая безопасность • технические меры • открытый ключ...
milanavornik
25.01.2023 22:13
Які пристрої використовують для введення та видення даних? ...
alenas000
17.04.2022 19:29
Складіть речення так, щоб подані слова виконували різну синтаксичну функцію: військовий (ім.) – військовий ( нове (ім.) – нове (прикм), дорослі (прикм.) – дорослі (і старий(ім.)...
ruslanpavlov8
17.04.2022 19:29
Внутренний кризис российской империи в конце 1916 – начале 1917 г....
Катеринатв2016
17.04.2022 19:29
Докажите, что в равнобедренном треугольнике авс от резок, соединяющий любую точку основания ав, от личную от а и в, с вершиной с, меньше боковой стороны....
Ерко365
17.04.2022 19:29
В250 мл воды растворяли 13,8 г натрия ,затем добавили 50 г 59% раствора фосфорной кислоты найти массовую долю соли в полученном растворе...
vikioria
17.04.2022 19:29
Составьте список сказок л.н. толстого. авторские в обработке в пересказе...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Внимание! Если программа не работает, обновите версию!
begin
1.To(ReadInteger('n=')).Select(t->t*t).Println
end.
Пример
n= 30
1 4 9 16 25 36 49 64 81 100 121 144 169 196 225 256 289 324 361 400 441 484 529 576 625 676 729 784 841 900
begin
write('n = ');
readln(n);
x := 1;
while sqr(x) < n do begin write(sqr(x),' ');
x := x + 1 end;
readln
end.