В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinaabpamenko1996
alinaabpamenko1996
16.06.2020 15:49 •  Информатика

Написать программу на c# работа с текстовыми файлами: имеется текстовый файл. выяснить, имеется ли в нем строка, начинающаяся с буквы «т». если да, то определить номер первой из таких строк. условие: текстовый файл для заранее создать в текстовом редакторе

Ответ:
Данька228228
Данька228228
08.10.2020 08:48
Using System;
using System.IO;

internal class Program
{
    public const string FILE = "test.txt";

    private static void Main()
    {
        try
        {
            using (var sr = File.OpenText(FILE))
            {
                string line;
                for (var i = 0; (line = sr.ReadLine()) != null; i++)
                {
                    if (!string.IsNullOrWhiteSpace(line) && line.Trim()[0] == 'т')
                    {
                        Console.WriteLine($"Строка {i} = {line}");
                        break;
                    }
                }
            }
        }
        catch(Exception e)
        {
            Console.WriteLine(e);
        }
        finally
        {
            Console.ReadLine();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?