В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GhostS1037
GhostS1037
05.12.2022 07:36 •  Информатика

Написать программу на языке программирования паскаль, который: 1) имеет 10 случайных элементов от 0 до 99 и выводит на экран 2) ищет индекс, равный 25, если такового нет, то сообщает об этом. премного .

Ответ:
КираМурТоп
КираМурТоп
13.08.2020 14:26
Var
  i:byte;
  a:array[1..10] of byte;
  Fortune:boolean;
begin
  Randomize;
  Write('Элементы массива: ');
  Fortune:=False;
  for i:=1 to 10 do begin
    a[i]:=Random(100);
    Fortune:=Fortune or (a[i]=25);
    Write(a[i],' ')
  end;
  Writeln;
  if not Fortune then Writeln('Нет элемента со значением 25')
end.

Тестовые запуски:
Элементы массива: 86 57 51 82 5 25 20 77 67 86

Элементы массива: 80 0 7 50 1 12 61 17 96 95
Нет элемента со значением 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?