В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу на языке паскаль числа по возрастанию.

Ответ:
areg122004
areg122004
07.06.2020 00:29
program parampampam; 
uses crt; 
var 
i: integer; {счетчик} 
s: integer; 
begin 
clrscr; {очистка экрана} 
writeln ('Программа выводит числа от 1 до 99, сумма цифр которых равна числу S'); 
writeln ('Введите число S, от 0 до 18: '); 
{ввод числа S с проверкой на корректность} 
repeat 
readln (s); 
if (s>18) or (s<0) then 
writeln ('Неверный ввод. Повторите') 
until (s<=18) and (s>=0); 
{вывод нужных чисел на экран (цикл с предусловием)} 
for i := 1 to 99 do 
if ((i div 10) + (i mod 10) = s) then {div дает целую часть, mod - остаток от деления} 
write (i, ' '); 
repeat until keypressed; {пустой цикл для задержки экрана до нажатия клавиши} 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?