В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maxbas1
maxbas1
29.12.2022 10:11 •  Информатика

Найти сумму первых n элементов. написать программу, если можно на паскале. pls, help

Ответ:
Федот2003
Федот2003
16.09.2020 20:26

var

 arr: array of real;

 sum: real;

 size, n, i: integer;

begin

 sum := 0;

 writeln('Введите размерность массива: ');

 readln(size);

 arr := new real[size];

 for i := 0 to size - 1 do

   arr[i] := 1 / power(2, i) + 1 / power(3, i);

 writeln('До какого элемента нужно считать сумму?');

 readln(n);

 for i := 0 to n - 1 do

   sum := sum + arr[i];

 writeln('Сумма первых n элементов = ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?