В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bahyt061089
bahyt061089
06.12.2022 17:57 •  Информатика

Напишите программу в паскаль для решения следующей : для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. иначе, выведите удвоенные значения этих чисел.

Ответ:
greennattea
greennattea
03.07.2020 10:30
Var a,b,c,d:real;
begin
readln(a,b,c,d);i
f (a<0) and (b/c=2) then
begin
writeln((a+b+c+d)/4);
if a*b*c*b>a+b+c+d then 
begin
writeln(a*b*c*b);
writeln(a+b+c+d);
end;
end
else
writeln(a*2,' ',b*2,' ',c*2,' ',d*2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?