В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Milkis051105
Milkis051105
05.04.2023 05:38 •  Информатика

Составьте программу, которая формирует массив, содержащий 16 случайных чисел, принадлежащих промежутку [-2; 3], и подсчитывает сумму отрицательных чисел.вывод в строку через запятую

Ответ:
zhjdjq2005
zhjdjq2005
26.05.2020 17:20

Program Program1;
var
i,sum:integer;
A: array [1..16] of integer;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=random(6)-2;
write(a[i],', ');
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln('Сумма отрицательных чисел равна',sum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?