В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
АндрейXXXМ
АндрейXXXМ
22.12.2021 06:23 •  Информатика

Даны натуральные числа n . составьте программу которая вычисляет сумму тех элементов последовательности которые кратны 3м

Ответ:
aminkaaverynova
aminkaaverynova
02.10.2020 21:47
Const n=100;
var a: array [1..n] of integer;
    s,i: integer;
begin
  s:=0;
  for i:=1 to n do 
{ вывод массива на экран  }
  begin 
    a[i]:=Random(100);
    write(a[i],' ');
    if (i mod 10 =0) then writeln();
  end;
 { подсчет суммы элементов, кратных 3 }   
  for i:=1 to n do   
      if (a[i] mod 3 =0) then s:=s+a[i]; 
 writeln('сумма равна   ',s);
end.             
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?