В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mashka150789
mashka150789
29.09.2022 10:56 •  Информатика

На вход программе два целых числа: 0 < n < = 12, 0 < = m < 60, указывающие момент времени “n часов m минут”. определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки на циферблате совпадут, не обязательно на каком-то делении. вещественную арифметику не использовать. abc pascal. пришлите скрин или полную запись программы

Ответ:
Zubkub
Zubkub
02.10.2020 21:18
Var h,m,c:integer;
begin
write('введите часы => ');
readln(h);
write('введите минуты => ');
readln(m);
if (h=12) then h:=0;
if (m < h*5) then c:=h*5-m; 
if (m > h*5) then c:=(60-m)+5;
writeln('стрелки совпадут через ',c,' минут');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?