В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kisslenkayaozax1i
kisslenkayaozax1i
15.04.2022 02:08 •  Информатика

Напишите программу,которая вычисляет сумму: а)первых n натуральных чисел; б)квадратов первых n натуральных чисел

Ответ:
gelyaangelmat
gelyaangelmat
03.07.2020 10:55
Решение на паскале:
а)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + i; // можно написать так inc(sum, i);
writeln('Сумма первых ', n, ' натуральных чисел = ', sum);
END.
б)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + sqr(i); 
writeln('Сумма квадратов первых ', n, ' натуральных чисел = ', sum);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?