В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ник13743803
Ник13743803
08.07.2021 13:34 •  Информатика

Решите в паскале,! напишите программу,которая заполняет массив из n элементов случайными целыми числами в диапазоне [a,b] и определяет количество элементов этого массива,у которых сумма цифр равна k.

Ответ:
Linamalinagamnina
Linamalinagamnina
07.10.2020 15:10
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

function sn(n:integer):integer; // сумма цифр числа
begin
  n:=Abs(n);
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;

begin
  var (n,a,b):=ReadInteger3('Введите n,a,b через пробел:');
  var m:=ArrRandom(n,a,b); m.Println;
  var k:=ReadInteger('k=');
  Writeln('Найдено чисел: ',m.Where(t->sn(t)=k).Count)
end.

Пример
Введите n,a,b через пробел: 15 -50 60
43 2 42 -26 -34 57 45 44 29 -41 -4 1 -17 38 -19
k= 7
Найдено чисел: 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?