В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mrskelet7
mrskelet7
11.12.2022 13:43 •  Информатика

Составьте программу которая выводит только те числа котрые делятся на 7

Ответ:
karinasing
karinasing
24.07.2020 06:28
Возможно нерационально но, пусть. Сначала вы вводите количество чисел, потом сами числа. Если число делится на 7 - то будет соответствующая строка, после чего будет предложено ввести новое число; Если нет, то будет предложено ввести новое число.
program cv;
var
a,i,chislo:integer;
begin
writeln ('Введите количество чисел');
readln (a);
for i:=1 to a do
begin
writeln ('Введите число');
readln (chislo);
if (chislo mod 7=0) then writeln ('Число ',chislo,' делится на 7.')
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?