В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Аляяяя0604
Аляяяя0604
30.05.2020 11:54 •  Информатика

Напишите программу которая выводит на экран (паскаль) а)положительные числа б)отрицательные в)четные г)нечетные на заметку(числа произвольные или любые (integer)) исправлено: даёться массив из n чисел вывести на экран количесвто чётных и нечётных,количество положительных и отрицательных элементов массивов

Ответ:
bogdanka1503p08ifa
bogdanka1503p08ifa
23.07.2020 14:29
Числа вводятся пользователем. Прикрепил скрин работы программы, вот сама программа:

var a:array[1..999]of integer;
i,n:integer;
begin
write ('Введите кол-во чисел: ');
readln (n);
for i:=1 to n do
begin
write ('Введите ',i,' число: ');
readln (a[i]);
end;
WRITELN;
write ('Числа введённые пользователем: ');
for i:=1 to n do
write (a[i],' ');
WRITELN;
WRITELN;
write ('Положительные: ');
for i:=1 to n do
begin
if a[i]>0 then write (a[i],' ');
end;
WRITELN;
write ('Отрицательные: ');
for i:=1 to n do
begin
if a[i]<0 then write (a[i],' ');
end;
WRITELN;
write ('Чётные: ');
for i:=1 to n do
begin
if a[i] mod 2 = 0 then write (a[i],' ');
end;
WRITELN;
write ('Нечётные: ');
for i:=1 to n do
begin
if a[i] mod 2 <> 0 then write (a[i],' ');
end;
end.

Напишите программу которая выводит на экран (паскаль) а)положительные числа б)отрицательные в)четные
0,0(0 оценок)
Ответ:
nastya2734
nastya2734
23.07.2020 14:29
Const
  nn = 100; { максимальное количество элементов }
var
  a:array[1..nn] of integer;
  i,n,k,kn,kp,ko,ke: integer;
begin
  Writeln('Введите количество элементов в массиве (n<=100): ');
  Readln(n);
  Writeln('Введите элементы массива');
  kn:=0; kp:=0; ko:=0; ke:=0;
  for i := 1 to n do
  begin
    Read(k); a[i]:=k;
    if k>0 then Inc(kp)
    else if k<0 then Inc(kn);
    if (k mod 2)=0 then Inc(ke) else Inc(ko)
  end;
  Writeln('Положительных элементов ',kp,', отрицательных ',kn);
  Writeln('четных элементов ',ke,', нечетных ',ko);
end.

Тестовое решение:
Введите количество элементов в массиве (n<=100):
13
Введите элементы массива
16 -5 8 21 0 -5 13 32 7 11 -4 2 -5
Положительных элементов 8, отрицательных 4
четных элементов 6, нечетных 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?