В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tcalala
tcalala
13.08.2021 02:37 •  Информатика

На vba: дано число. составить программу, которая определяет. входит ли в него цифра 3.

Ответ:
darya21072005
darya21072005
15.06.2020 21:50

Дам 2 кода на с++ и на паскаль, попробуешь перевести на VBA . не сложно.

с++

int a,b,count(0);;
cin>>a;
while(a>0)
{
b=a%10;
if (b==3) count++;
a/=10;
}
if (count > 0) cout<<"OK";
else cout<<"NO";

 

pascal как то так

uses crt;

var a,b,count:integer;
begin
readln(a);
count:=0;

while a > 0 do
begin
b:=a mod 10;
if b = 3then inc(count);
a:=a div 10;
end;
if count > 0 then writeln('ok')
else
writeln('NO');
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?