В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natusy2411
natusy2411
08.03.2021 09:34 •  Информатика

Составить программу по нахождению стороны равностороннего треугольника по периметру. что я сделал не так?

Ответ:
Sashas16
Sashas16
26.05.2020 04:45

Переменные с типом integer нельзя делить. Надо вместо integer в разделе var поставить real

0,0(0 оценок)
Ответ:
pomosh221314
pomosh221314
26.05.2020 04:45

У равностороннего треугольника все стороны равны, а значит Р=3а, > а=Р/3

Естественно, как указано ниже, а- вещественные число, а Р принимает только целые значения, ибо при выполнения программы компьютером возникнет ошибка.

Program Long side ;

Var a:real;

Var P:Integer;

Begin

Write ("Perimeter of the equilateral triangle") ;

Read(P)

a:=P/3;

Write("The Length Of the equilateral triangle side is equal to" a) ;

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?