В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bobbygrenn
bobbygrenn
05.02.2021 19:33 •  Информатика

Напишите программу, которая получает с клавиатуры трёхзначное число и записывает в логическую переменную значение «да» (true), если это все его цифры одинаковы. после этого на экран выводится ответ на вопрос: «верно ли, что все цифры введённого числа одинаковы? ». паскаль! ) с логической переменной

Ответ:
AliceGo2018
AliceGo2018
10.10.2020 01:32

program znanija;

var

answer: boolean;

a,b,c,d: integer;

begin

readln(a);

b := a mod 10;

c := a div 100;

d := a div 10 mod 10;

if (b=c) and (c=d) then

answer := true;

if answer = true then

writeln ('Да, верно')

else

writeln ('Нет, не верно');

end.

0,0(0 оценок)
Ответ:
Zazej
Zazej
10.10.2020 01:32

var

   a : integer;

   d : boolean;

   

begin

   write('Введите трехзначное число -- ');

   readln(a);

   write('Верно ли, что все цифры введённого числа одинаковы? -- ');

   if a mod 10 and a div 10 mod 10 = a div 100 then d := true else d := false;

   if d then writeln('ДА') else writeln('НЕТ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?