В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
leesasha083
leesasha083
12.07.2021 16:19 •  Информатика

Надобно написать программу в паскале. заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части. пример: 1 -2 6 -8 -3 | 5 -7 1 0 -4 -3 -8 6 -2 1 | -4 0 1 -7 5

Ответ:
blablabla43
blablabla43
20.05.2020 16:24
Program xax;
var i:shortint;
    a,b: array [-10..10] of byte;
begin
   randomize;
   for i:=-10 to 10 do
   begin
      a[i]:=random(100);
      write(a[i],'  ');
   end;
   writeln;
   for i:=-10 to -1 do
      b[i]:=a[-11-i];
  for i:=1 to 10 do
      b[i]:=a[11-i];
  b[0]:=a[0];
  for i:=-10 to 10 do
      write(b[i],'  ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?