В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Karelovamark
Karelovamark
14.07.2021 18:22 •  Информатика

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45++115 2)составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150 3)дано вещественное число а и целое число n(> 0).испульзуя один цикл вывести все целые степени числа а от 1 до n while

Ответ:
azimova0113
azimova0113
12.07.2020 11:19
1)var i,sum:integer;
begin
sum:=0;
i:=45;
while (i<=115) do begin
sum:=sum+i;
i:=i+1;
end;
writeln( 'Сумма = ', sum );
end.
2)var i:integer;
begin
i:=2;
while (i<=150) do begin
If (i mod 2=0) and (i mod 13=0) then
writeln(i);
i:=i+1;
end;end.
3)var c,A,i,N:integer;
begin
write('Введите целое число (N>0) N = ');read(N);
write('Введите целое число A = ');read(A);
c:=1;
i:=1;
while (i<=N) do begin
c:=c*A;
i:=i+1;
Writeln('A в степени ',i,' := ',c);
end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?