В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Matvei200322
Matvei200322
11.10.2022 17:26 •  Информатика

Составьте программу,которая формирует массив из 10 случайных чисел,принадлежащих промежутку [-9; 9] , и выводит эти числа в столбец.

Ответ:
данил1780
данил1780
10.07.2020 12:25
Const
  n = 10;

var
  x: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива:');
  for i := 1 to n do
  begin
    x[i] := Random(19) - 9;
    Writeln(x[i])
  end
end.

Тестовое решение:

Элементы массива:
-9
0
-3
4
3
9
-7
9
6
-6
0,0(0 оценок)
Ответ:
Марина1000001
Марина1000001
10.07.2020 12:25
Program zz;
var a:array[1..10] of integer;     
i:integer;
begin 
for i:=1 to 10 do 
a[i]:=random(19)-9; 
for i:=1 to 10 do 
writeln(a[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?