В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RaNoM
RaNoM
25.07.2021 09:16 •  Информатика

Напишите программу определения простого числа в паскале

Ответ:
Шатунов1
Шатунов1
08.07.2020 01:41
Var
  i,n,m,s:integer;
begin
  write('Введите число: ');
  readln(n);
  if n mod 2=0 then
    writeln('Число не является простым')
  else begin
    m:=trunc(sqrt(n));
    i:=3;
    while (n mod i <> 0) and (i<=m) do i:=i+2;
    if i<=m then writeln('Число не является простым')
    else writeln('Число является простым')
  end
end.
0,0(0 оценок)
Ответ:
мяеенри
мяеенри
08.07.2020 01:41
Program chisla;
uses crt;
var i,a,k: integer;
begin
clrscr;
write('введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then k:=k+1;
if k=0 then write('простое')
else writeln('не простое');
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?