В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sasha030506
Sasha030506
26.05.2022 05:15 •  Информатика

Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно), влево на r элементов.

Ответ:
Еролггштши
Еролггштши
07.07.2020 13:28
Var
   i,k,m,r,p,j:integer;
   a:array[1..10]of integer;
begin
writeln('Массив: ');
for i:=1 to 10 do
  begin
  a[i]:=random(10);
  write(a[i],' ');
  end;
writeln;
write('Введите K,M,R: ');
readln(k,m,r);
for i:=1 to r do
  begin
  j:=k;
  p:=a[j];
  while j<m do
    begin
    a[j]:=a[j+1];
    j:=j+1
    end;
  a[j]:=p;
  end;
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?